2013/09/01

【mikutter】最下のツイート選択時にショートカットキーで下移動後カーソル移動できくなる問題修正

select_next_patch


mikutterで一番下のツイートが選択されている時にショートカットキーに割り当てたselect_next(一つ下のメッセージを選択)を使用すると、その後select_next(一つ下のメッセージを選択)とselect_prev(一つ上のメッセージを選択)が使えなくなるという問題を修正するパッチです(キーボードの↓キーを使用しての移動の場合は問題なし)。

プラグイン版→ mikutter_select_next_patch.rb

ver. 0.2.2.1318との差分パッチ→ mikutter_select_next_patch_022_1318.diff

ver. 0.2.2.1328との差分パッチ→ mikutter_select_next_patch_022_1328.diff


プラグイン版は他のmikutterプラグインと同様にplugin/フォルダに入れるだけで動作します。


差分パッチは
cd core/plugin/gtk/
patch < mikutter_select_next_patch_022_XXXX.diff
※ XXXXは対応するver.
のようにしてパッチして下さい。

追記(2013/09/24):
プラグイン版がmasterブランチの方で動作しなかった問題を修正しました。


posted by @hiroi01

0 件のコメント:

コメントを投稿